Author Topic: Golf GTI 87 K-Jetronic start problems  (Read 2480 times)

Offline jpjones101

  • Just got here
  • *
  • Posts: 1
Golf GTI 87 K-Jetronic start problems
« on: 07 August 2020, 13:36 »
Hello all

Having start issues with my Golf Mk2 Gti, I have been through all the cold/hot start posts but nothing seems to pinpoint the issue.

I've highlighted 3 start scenarios below with both CSV plugged in and plugged out.

Once warmed up the car fuels perfectly on power and idle.

Cold Start (more than 12hrs since last run)

CSV off - Instant start, idles good
CSV on - Instant start, idles good


Warm Start (1-4hrs since last run)

CSV off - no start, 3 - 5 or more long cranks with 10 secs between cranks to start, idle good
CSV on - rough start, rough idle for a good 5 mins, can cut out


Hot Start (5 - 30mins since last run)

CSV off - no start, 3 - 5 or more long cranks with 10 seconds between cranks to start, idle good
CSV on - rough start, rough idle for a good 5 mins, can cut out


Priming the fuel pump 2-3 times (ignition on & off) helps sometimes, reduces crank by maybe 1-2 times, mixed luck.


Part Price:
CSV - £170
Fuel Regulator - £200
WUR - £500
Blue temp sender £6 (trying this first)

Any ideas of which part is the culprit ? as they are all expensive I don't want to buy something I don't need.

Thanks ! Any feedback welcome.

Offline rickygolf83

  • Just got here
  • *
  • Posts: 1
Re: Golf GTI 87 K-Jetronic start problems
« Reply #1 on: 12 August 2020, 16:57 »
I get similar long starts when engine warm, and a rough idle when starting from cold.  My mechanic / mate reckons its the WUR and i have bought a rebuild kit from Germany for it. Yet to build up to fitting it yet lol

https://www.ebay.co.uk/itm/383249981094