Author Topic: Regarding the Discover Pro  (Read 1037 times)

Offline Buzz’d

  • Just got here
  • *
  • Posts: 2
Regarding the Discover Pro
« on: 16 March 2019, 15:05 »
So, I just sold my mk6 GTI (2012 model), and bought a used VW e-Golf SEL Premium (2016 model).
I had retrofitted my mk6 GTI with the RCD330 Headunit that had Apple Carplay, Android Auto and Mirrorlink which worked great. The e-Golf has the Discover Pro Headunit which I was very much looking forward to, based on the mostly positive reviews I’ve read about it. But I was surprised to find out that it’s very laggy even compared to the chinese made RCD330. What I noticed is when I’m on carplay and want to scroll through the apps, it’s slow to respond and the transition from one “page” of apps to the next is not smooth at all, the same goes for switching between the radio and media or scrolling through the car’s options.
I’ve watched a few reviews of the Discover Pro on Youtube and it doesn’t seem like its laggy at all.
So, I wanted to know how your experience is with the Discover Pro? Anyone experiencing this issue? Is this how it should be? If not, is there anything to be done?

Offline mcmaddy

  • Forum addict
  • *
  • Posts: 4,164
Re: Regarding the Discover Pro
« Reply #1 on: 24 March 2019, 14:43 »
I've got nav pro in my 2016 GTi and it's not laggy at all. You may have to visit your dealer and see if any software updates are available for your unit. Doesn't sound right though.
Gti PP, Tungsten, Tech & Parking packs, HBA

Offline Gnasher

  • I live here
  • *****
  • Posts: 951
  • Formerly GnasherVXR
Re: Regarding the Discover Pro
« Reply #2 on: 08 April 2019, 14:14 »
Could try a reset first to see if that helps - just hold the on/off button down for 10 seconds or so.
2014 Golf GTI (PP) in Pure White with
Vienna Leather, Keyless Entry, High Beam Assist, Park Assist, Rear View Camera.

Milltek Exhaust, Eibach Sportlines, 19" BBS SR wheels