Author Topic: Anyone had similar problems?  (Read 6941 times)

Offline luke

  • I live here
  • *****
  • Posts: 1,217
  • Location: Hinckley, Leicestershire
  • When in doubt, whip it out!
Anyone had similar problems?
« on: 07 January 2014, 21:27 »
Got a 54 plate a3 2.0 tdi sport 140, eml came on a week after I bought it, garage said egr control module, had that replaced and eml back on and going back into limp mode with spirited driving, and now the garage is saying it's over boosting but apparently turbo and surrounding pipes are fine
Audi A3 tdi sport dsg

Offline Rhyso

  • Global Moderator
  • Sir Postalot
  • *****
  • Posts: 26,847
    • Kinetic Tuning
Re: Anyone had similar problems?
« Reply #1 on: 07 January 2014, 22:15 »
Control module?  :huh:

Would have thought they would have replaced the EGR unit itself  :undecided:

Offline luke

  • I live here
  • *****
  • Posts: 1,217
  • Location: Hinckley, Leicestershire
  • When in doubt, whip it out!
Re: Anyone had similar problems?
« Reply #2 on: 08 January 2014, 07:40 »
Control module?  :huh:

Would have thought they would have replaced the EGR unit itself  :undecided:
Egr control module/unit, little black box on top by the bulk head, apparently when plugged in it said it was a break in the wire or no power to it, but now over boosting, the egr valve has been cleaned and will be having that blanked off when the blanking plate arrives
Audi A3 tdi sport dsg

Offline Rhyso

  • Global Moderator
  • Sir Postalot
  • *****
  • Posts: 26,847
    • Kinetic Tuning
Re: Anyone had similar problems?
« Reply #3 on: 08 January 2014, 08:07 »
How many miles has the car done?? Is it on its original turbo??

What are you doing when you hit limp mode? i.e gear, speed etc

Also if you blank the EGR off and it hasnt been mapped out that will throw up the EML and a code
« Last Edit: 08 January 2014, 08:10 by Rhyso »

Offline luke

  • I live here
  • *****
  • Posts: 1,217
  • Location: Hinckley, Leicestershire
  • When in doubt, whip it out!
Re: Anyone had similar problems?
« Reply #4 on: 08 January 2014, 08:47 »
How many miles has the car done?? Is it on its original turbo??

What are you doing when you hit limp mode? i.e gear, speed etc

Also if you blank the EGR off and it hasnt been mapped out that will throw up the EML and a code
Mileage shows 120k but mot shows 180k, couldn't tell you about the turbo, garage said they gave it a check over and was fine, engine runs good until that happened, it's dsg so unsure on gear as I just stick it in drive, goes in limp mode when driven above 3-4k, I'd get it mapped out when it's done so I know it's all sorted
Audi A3 tdi sport dsg

Offline Rhyso

  • Global Moderator
  • Sir Postalot
  • *****
  • Posts: 26,847
    • Kinetic Tuning
Re: Anyone had similar problems?
« Reply #5 on: 08 January 2014, 11:39 »
At that mileage i would presume the turbo is all but fit for the bin  :sad:

What checks did the garage do on the turbo?? Have they driven it and hit limp mode??

Offline luke

  • I live here
  • *****
  • Posts: 1,217
  • Location: Hinckley, Leicestershire
  • When in doubt, whip it out!
Re: Anyone had similar problems?
« Reply #6 on: 08 January 2014, 12:09 »
At that mileage i would presume the turbo is all but fit for the bin  :sad:

What checks did the garage do on the turbo?? Have they driven it and hit limp mode??
Not 100% on what they've done, just said that they've checked it over and checked the hoses, will find out later after work as they're next door
Audi A3 tdi sport dsg

Offline luke

  • I live here
  • *****
  • Posts: 1,217
  • Location: Hinckley, Leicestershire
  • When in doubt, whip it out!
Re: Anyone had similar problems?
« Reply #7 on: 24 January 2014, 11:57 »
After days of being in the garage it is now down to a faulty ecu, it has been snapped open, fiddled with then siliconed back together, will be sent off for repair Monday and hopefully be the last of the problems
Audi A3 tdi sport dsg

Offline Rhyso

  • Global Moderator
  • Sir Postalot
  • *****
  • Posts: 26,847
    • Kinetic Tuning
Re: Anyone had similar problems?
« Reply #8 on: 24 January 2014, 20:49 »
Did they check the fuses for the EGR valve? When the valve fails they can short circuit the fuse......

Offline luke

  • I live here
  • *****
  • Posts: 1,217
  • Location: Hinckley, Leicestershire
  • When in doubt, whip it out!
Re: Anyone had similar problems?
« Reply #9 on: 24 January 2014, 20:59 »
Did they check the fuses for the EGR valve? When the valve fails they can short circuit the fuse......
Couldn't tell you, I'll ask Monday, I know they cleaned the valve again, this cars getting a bit costly, as all money is going towards moving out in a few weeks
Audi A3 tdi sport dsg