Author Topic: Faulty MAF sensor.  (Read 79304 times)

Offline D1andonlyantman

  • GTI forum regular
  • ***
  • Posts: 143
Re: Faulty MAF sensor.
« Reply #30 on: 01 October 2013, 03:05 »
Hi. I recently bought a 03 gti 180bhp 6 speed and am wondering if it has a faulty MAF. There is an exhaust light on the dash the PO said was from an aftermarket hose that doesn't have a sensor but the traction control light is also on. My friend who specialises in German cars says he thinks the MAF may be faulty but he hasn't had the time to have a good look yet. The other day I had it at 40mpg according to the dash so mileage seems ok, the idle is smooth and it doesn't stall on it own. Because the TC isn't working it spins the wheels up in first when I put my foot down, even if I'm already moving, and it even gives a little spin and I change into second so I guess power isn't down but after second the car does feel a bit slow but I have no idea if I just have too high expectations. The other day I went to an abandoned airfield and put my foot to the floor. I got it up to 125 in 4th at around 4.5k and the revs were barely climbing anymore. I would need to get it on a motorway to get anywhere near top speed I reckon. Is this normal or could this be low power/a flat spot? This is my second car so I have hardly anything to compare to other than my motorbikes which are obviously a lot faster so I really don't know if im expecting too much or if there could be a problem??

Edit: also I just drove the car home and gave it a good thrash and when I got to some lights and put the clutch in the revs hesitated before they dropped. I gave it some throttle again and they stayed up for a second before they dropped again. First time it's done that and I'm fairly sure that's not normal. Maybe a sign it's running a bit rich sometimes??

 Any ideas appreciated
« Last Edit: 01 October 2013, 06:43 by D1andonlyantman »
MKIV AUQ - RamAir Induction Kit, Forge007p, (Custom Exhaust, Decent TIP, N249 Bypass and remap coming soon)

TRASHED BY SOME BELLEND WHO CANT DRIVE

Replaced with Leon Cupra 225, RamAir CAI, Forge 007p, Badger5 TIP, N249 bypass, Scorpion Decat and Catback, R-tech remap pushing approx 275bhp :-)

Offline WadGTI

  • Here all the time
  • ****
  • Posts: 461
  • Golf GTI'er
Re: Faulty MAF sensor.
« Reply #31 on: 01 October 2013, 12:29 »
I would get it scanned pronto. and go from there.  :smiley:

Offline D1andonlyantman

  • GTI forum regular
  • ***
  • Posts: 143
Re: Faulty MAF sensor.
« Reply #32 on: 06 October 2013, 01:28 »
I got it scanned. My mate wasn't happy with the MAF so I changed that today. The traction control now works but im still not 100% on the amount of power. Going to get the exhaust warning light sorted first and then see what's what. Definitely a step in the right direction though :-)
MKIV AUQ - RamAir Induction Kit, Forge007p, (Custom Exhaust, Decent TIP, N249 Bypass and remap coming soon)

TRASHED BY SOME BELLEND WHO CANT DRIVE

Replaced with Leon Cupra 225, RamAir CAI, Forge 007p, Badger5 TIP, N249 bypass, Scorpion Decat and Catback, R-tech remap pushing approx 275bhp :-)